#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d+)(\s*[x.][x.\s]*)(\d+)"
Local $sString = "total 19xx.100" & @CRLF & _
"total 19x..100" & @CRLF & _
"total 19..100" & @CRLF & _
"total 19x .100"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)