import Foundation
let pattern = #"(\d+)(\s*[x.][x.\s]*)(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
total 19xx.100
total 19x..100
total 19..100
total 19x .100
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)