// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+)(\s*[x.][x.\s]*)(\d+)").unwrap();
let string = "total 19xx.100
total 19x..100
total 19..100
total 19x .100";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}