$re = '/(\d+)(\s*[x.][x.\s]*)(\d+)/';
$str = 'total 19xx.100
total 19x..100
total 19..100
total 19x .100';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;