#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z][a-z]+ [A-Z](?:[a-z]+|\.(?: [A-Z]\.)?)$"
Local $sString = "John Doe" & @CRLF & _
"John D." & @CRLF & _
"John D. D." & @CRLF & _
"" & @CRLF & _
"John D. D. " & @CRLF & _
"John D. D." & @CRLF & _
"John D.oe" & @CRLF & _
"John D. D.$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")