import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z][a-z]+ [A-Z](?:[a-z]+|\\.(?: [A-Z]\\.)?)$";
final String string = "John Doe\n"
+ "John D.\n"
+ "John D. D.\n\n"
+ "John D. D. \n"
+ "John D. D.\n"
+ "John D.oe\n"
+ "John D. D.$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}