$re = '/^[A-Z][a-z]+ [A-Z](?:[a-z]+|\.(?: [A-Z]\.)?)$/m';
$str = 'John Doe
John D.
John D. D.
John D. D.
John D. D.
John D.oe
John D. D.$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);