package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][a-z]+ [A-Z](?:[a-z]+|\.(?: [A-Z]\.)?)$`)
var str = `John Doe
John D.
John D. D.
John D. D.
John D. D.
John D.oe
John D. D.$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}