using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\G(?!^)|\@apply) ([^\s\;]*|[\p{P}]*)";
string substitution = @" tw-$1";
string input = @"/* Adds custom prefix to tailwind classes */
/* https://v2.tailwindcss.com/docs/just-in-time-mode#:~:text=Don%27t%20use%20spaces%20in%20arbitrary%20values */
@apply rounded text-md;
@apply rounded text-md aaaa;
@apply grid-cols-[1fr,700px,2fr] text-[var(--mystery-var)] text-[color:var(--mystery-var)];
@apply rounded text-md w-[calc(asdasd-ssd)];";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}