import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\G(?!^)|\\@apply) ([^\\s\\;]*|[\\p{P}]*)";
final String string = "/* Adds custom prefix to tailwind classes */\n"
+ "/* https://v2.tailwindcss.com/docs/just-in-time-mode#:~:text=Don%27t%20use%20spaces%20in%20arbitrary%20values */\n"
+ "@apply rounded text-md;\n"
+ "@apply rounded text-md aaaa;\n"
+ "@apply grid-cols-[1fr,700px,2fr] text-[var(--mystery-var)] text-[color:var(--mystery-var)];\n"
+ "@apply rounded text-md w-[calc(asdasd-ssd)];";
final String subst = " tw-$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}