const regex = /(?<=\G(?!^)|\@apply) ([^\s\;]*|[\p{P}]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\G(?!^)|\\@apply) ([^\\s\\;]*|[\\p{P}]*)', 'gm')
const str = `/* Adds custom prefix to tailwind classes */
/* https://v2.tailwindcss.com/docs/just-in-time-mode#:~:text=Don%27t%20use%20spaces%20in%20arbitrary%20values */
@apply rounded text-md;
@apply rounded text-md aaaa;
@apply grid-cols-[1fr,700px,2fr] text-[var(--mystery-var)] text-[color:var(--mystery-var)];
@apply rounded text-md w-[calc(asdasd-ssd)];`;
const subst = ` tw-$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);