re = /(?<=\G(?!^)|\@apply) ([^\s\;]*|[\p{P}]*)/m
str = '/* Adds custom prefix to tailwind classes */
/* https://v2.tailwindcss.com/docs/just-in-time-mode#:~:text=Don%27t%20use%20spaces%20in%20arbitrary%20values */
@apply rounded text-md;
@apply rounded text-md aaaa;
@apply grid-cols-[1fr,700px,2fr] text-[var(--mystery-var)] text-[color:var(--mystery-var)];
@apply rounded text-md w-[calc(asdasd-ssd)];'
subst = ' tw-$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result