using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)done$\s+.*226-$";
string input = @"some text here done
12345678_123456 226-
more text
some more text here done
12345678_234567 226-";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}