package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)done$\s+.*226-$`)
var str = `some text here done
12345678_123456 226-
more text
some more text here done
12345678_234567 226-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}