re = /(?m)done$\s+.*226-$/
str = 'some text here done
12345678_123456 226-
more text
some more text here done
12345678_234567 226-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end