$re = '/(?m)done$\s+.*226-$/';
$str = 'some text here done
12345678_123456 226-
more text
some more text here done
12345678_234567 226-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);