package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((?:s?he(?: i|')s|(?:you|they|we)(?: a|')re|I(?: a|')m).{1,20})\b(Fan)(s?)\b`)
var str = `He's the bigest fan I know.
I am a huge fan of his.
I know she has lots of fans in his club
I was cold and turned on the fan
An air conditioner is better than 2 fans at cooling.`
var substitution = "\1\2atic\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}