const regex = /((?:s?he(?: i|')s|(?:you|they|we)(?: a|')re|I(?: a|')m).{1,20})\b(Fan)(s?)\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:s?he(?: i|\')s|(?:you|they|we)(?: a|\')re|I(?: a|\')m).{1,20})\\b(Fan)(s?)\\b', 'gi')
const str = `He's the bigest fan I know.
I am a huge fan of his.
I know she has lots of fans in his club
I was cold and turned on the fan
An air conditioner is better than 2 fans at cooling.`;
const subst = `\1\2atic\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);