// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((?:s?he(?: i|')s|(?:you|they|we)(?: a|')re|I(?: a|')m).{1,20})\b(Fan)(s?)\b").unwrap();
let string = "He's the bigest fan I know.
I am a huge fan of his.
I know she has lots of fans in his club
I was cold and turned on the fan
An air conditioner is better than 2 fans at cooling.";
let substitution = "\\1\\2atic\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}