$re = '/((?:s?he(?: i|\')s|(?:you|they|we)(?: a|\')re|I(?: a|\')m).{1,20})\b(Fan)(s?)\b/i';
$str = 'He\'s the bigest fan I know.
I am a huge fan of his.
I know she has lots of fans in his club
I was cold and turned on the fan
An air conditioner is better than 2 fans at cooling.';
$subst = "\1\2atic\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;