using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bcommon\b(?!.*\.min\.js$).*\.js$";
string input = @"~/dist/common.js
~/dist/common.9cf5748e0e7fc2928a07.js";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}