re = /\bcommon\b(?!.*\.min\.js$).*\.js$/m
str = '~/dist/common.js
~/dist/common.9cf5748e0e7fc2928a07.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end