$re = '/\bcommon\b(?!.*\.min\.js$).*\.js$/m';
$str = '~/dist/common.js
~/dist/common.9cf5748e0e7fc2928a07.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);