const regex = /\bcommon\b(?!.*\.min\.js$).*\.js$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bcommon\\b(?!.*\\.min\\.js$).*\\.js$', 'gm')
const str = `~/dist/common.js
~/dist/common.9cf5748e0e7fc2928a07.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}