using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([HW])][^][\d]*(\d+(?:\.\d+)?)";
string input = @"[H] $10 [W] 100 credits
[H] $10.55 [W] 100.01 credits";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}