const regex = new RegExp('\\[([HW])][^][\\d]*(\\d+(?:\\.\\d+)?)', 'gm')
const str = `[H] \$10 [W] 100 credits
[H] \$10.55 [W] 100.01 credits`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}