re = /\[([HW])][^][\d]*(\d+(?:\.\d+)?)/m
str = '[H] $10 [W] 100 credits
[H] $10.55 [W] 100.01 credits'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end