// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[([HW])][^][\d]*(\d+(?:\.\d+)?)").unwrap();
let string = "[H] $10 [W] 100 credits
[H] $10.55 [W] 100.01 credits";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}