import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"\\K[\\w-]+(\\.jpg)(?=\")";
final String string = ";s:27:\"2018/08/hello-there-003.jpg\";s:5:\"sizes\";a:23:{s:9:\"thumbnail\";a:4:{s:4:\"file\";s:27:\"hello-there-003-150x150.jpg\";s:5:\"width\";i:150;s:6:\"height\";i:150;s:9:\"mime-type\";s:10:\"image/jpeg\";}s:6:\"medium\";a:4:{s:4:\"file\";s:27:\"hello-there-003-300x200.jpg\"\n";
final String subst = "replacement$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}