import re
regex = re.compile(r"\"\K[\w-]+(\.jpg)(?=\")")
test_str = (";s:27:\"2018/08/hello-there-003.jpg\";s:5:\"sizes\";a:23:{s:9:\"thumbnail\";a:4:{s:4:\"file\";s:27:\"hello-there-003-150x150.jpg\";s:5:\"width\";i:150;s:6:\"height\";i:150;s:9:\"mime-type\";s:10:\"image/jpeg\";}s:6:\"medium\";a:4:{s:4:\"file\";s:27:\"hello-there-003-300x200.jpg\"\n")
subst = "replacement$1"
result = regex.sub(subst, test_str)
if result:
print(result)