import Foundation
let pattern = #""\K[\w-]+(\.jpg)(?=")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
;s:27:"2018/08/hello-there-003.jpg";s:5:"sizes";a:23:{s:9:"thumbnail";a:4:{s:4:"file";s:27:"hello-there-003-150x150.jpg";s:5:"width";i:150;s:6:"height";i:150;s:9:"mime-type";s:10:"image/jpeg";}s:6:"medium";a:4:{s:4:"file";s:27:"hello-there-003-300x200.jpg"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"replacement$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)