import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(ucode|cryptsetup|linux|nvidia|mesa|systemd|wayland|xf86-video|xorg|firefox)";
final String string = "firefox 79.0-1 -> 80.0-1\n"
+ "jasper 2.0.17-1 -> 2.0.19-1\n"
+ "partclone 0.3.12-1 -> 0.3.15-1\n"
+ "sqlite 3.32.3-1 -> 3.33.0-1\n"
+ "sublime-merge 2030-1 -> 2031-1\n"
+ "talloc 2.3.1-2 -> 2.3.1-3\n"
+ "xterm 358-1 -> 359-1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}