$re = '/(ucode|cryptsetup|linux|nvidia|mesa|systemd|wayland|xf86-video|xorg|firefox)/m';
$str = 'firefox 79.0-1 -> 80.0-1
jasper 2.0.17-1 -> 2.0.19-1
partclone 0.3.12-1 -> 0.3.15-1
sqlite 3.32.3-1 -> 3.33.0-1
sublime-merge 2030-1 -> 2031-1
talloc 2.3.1-2 -> 2.3.1-3
xterm 358-1 -> 359-1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);