import Foundation
let pattern = #"(ucode|cryptsetup|linux|nvidia|mesa|systemd|wayland|xf86-video|xorg|firefox)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
firefox 79.0-1 -> 80.0-1
jasper 2.0.17-1 -> 2.0.19-1
partclone 0.3.12-1 -> 0.3.15-1
sqlite 3.32.3-1 -> 3.33.0-1
sublime-merge 2030-1 -> 2031-1
talloc 2.3.1-2 -> 2.3.1-3
xterm 358-1 -> 359-1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)