#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*"
Local $sString = "Leon’s API key: uy3829hoipufhp9w8aanoi (don’t use)" & @CRLF & _
"Peter’s API key: 489qp3nfshfSsphf09HWan " & @CRLF & _
"Eric’s API key: DEMO_KEY he used this in lecture!" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")