re = /.*/m
str = 'Leon’s API key: uy3829hoipufhp9w8aanoi (don’t use)
Peter’s API key: 489qp3nfshfSsphf09HWan
Eric’s API key: DEMO_KEY he used this in lecture!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end