// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*").unwrap();
let string = "Leon’s API key: uy3829hoipufhp9w8aanoi (don’t use)
Peter’s API key: 489qp3nfshfSsphf09HWan
Eric’s API key: DEMO_KEY he used this in lecture!
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}