package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*`)
var str = `Leon’s API key: uy3829hoipufhp9w8aanoi (don’t use)
Peter’s API key: 489qp3nfshfSsphf09HWan
Eric’s API key: DEMO_KEY he used this in lecture!
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}