import re
regex = re.compile(r"^#TR\|\d+[^\t]+\tIdentifier\|\d+[^\t]+\t(FC\d+)\/(\d+)", flags=re.MULTILINE)
test_str = ("#TR|1 Normal Identifier|2 Normal FC0018724/001\n"
"#TR|1 Normal Identifier|2 Normal FC0013224/001\n"
"#TR|1 Normal Identifier|2 Normal FC001111113/001\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")