package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)\[([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20}\]`)
    var str = `[118.0 (09/01/23 17:08:00), 216.0 (09/01/23 17:07:00), 88.0 (09/01/23 17:06:00)]`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}