re = /\[([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20}\]/m
str = '[118.0 (09/01/23 17:08:00), 216.0 (09/01/23 17:07:00), 88.0 (09/01/23 17:06:00)]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end