import re
regex = re.compile(r"\[([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20}\]", flags=re.MULTILINE)
test_str = "[118.0 (09/01/23 17:08:00), 216.0 (09/01/23 17:07:00), 88.0 (09/01/23 17:06:00)]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")