using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=[^\p{L}\p{N}])|^)42(?=[^\p{L}\p{N}]|$)";
string input = @"42
hello 42
hello-42-
été42
042
4 2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}