$re = '/(?:(?<=[^\p{L}\p{N}])|^)42(?=[^\p{L}\p{N}]|$)/';
$str = '42
hello 42
hello-42-
été42
042
4 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);