#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:2[0-3]|[01]\d|\d):[0-5]\d$"
Local $sString = "10:30" & @CRLF & _
"18:15" & @CRLF & _
"6:24" & @CRLF & _
"44:99" & @CRLF & _
"00:19" & @CRLF & _
"00:00" & @CRLF & _
"24:59" & @CRLF & _
"23:59" & @CRLF & _
"1:12" & @CRLF & _
"1:60" & @CRLF & _
"13:42"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")