using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:2[0-3]|[01]\d|\d):[0-5]\d$";
string input = @"10:30
18:15
6:24
44:99
00:19
00:00
24:59
23:59
1:12
1:60
13:42";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}