import re
regex = re.compile(r"((((о|е|ё)(в|ц)а?)|((ы|и)на?))|(о|а(й|к|у|ч)?)|(к((о|и)й|ая))|(и(ч|ц))|((ы|и)(х|й)|ая)|((у|ю|о)(к|н|б))|(штейн|манн?|сон))\b", flags=re.MULTILINE)
test_str = ("Смирнов/Cмиров\n"
"Николаев/Николаева\n"
"Никитин/Никитина\n"
"Киселёв/Киселёва\n"
"Пятницын/Пятницына\n"
"Крыленко\n"
"Хованский/Хованская\n"
"Калита\n"
"Шемяка\n"
"Донской/Донская\n"
"Теплых\n"
"Усович\n"
"Царук\n"
"Нагорный/Нагорная\n"
"Деньнуб\n"
"Заренок\n"
"Шевчук\n"
"Драгун\n"
"Харинтон\n"
"Горбатых\n"
"Фидорец\n"
"Слободенюк\n"
"Кравчук\n"
"Голицын\n"
"Лифшиц\n"
"Либерман\n"
"Капица\n"
"Айнштейн\n"
"Лазерсон\n"
"Байдачный/Байдачная\n"
"Зварыкин/Зварыкина\n"
"Коллонтай\n"
"Cобчак\n"
"Ландау\n"
"Василец\n"
"Кучерявый\n"
"Бородач\n"
"Грицюк\n"
"Радаев\n"
"Белаец\n"
"Деев\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")