using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[img\].+\n)(\[img\].+\n)*";
string substitution = @"$1";
string input = @"subject1
image url follows here
[img]http:f6.abc.com/246421f...
[img]http:f6.abc.com/246421d...
[img]http:f6.abc.com/246421h...
[img]http:f6.abc.com/246421m...
download url follows here
[url]link1[/url]
subject2
image url follows here
[img]http:z.uvw.com/7862252...
[img]http:z.uvw.com/4621017...
[img]http:z.uvw.com/4728212...
[img]http:z.uvw.com/78293.5...
download url follows here
[url]link2[/url]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}