package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[img\].+\n)(\[img\].+\n)*`)
var str = `subject1
image url follows here
[img]http:f6.abc.com/246421f...
[img]http:f6.abc.com/246421d...
[img]http:f6.abc.com/246421h...
[img]http:f6.abc.com/246421m...
download url follows here
[url]link1[/url]
subject2
image url follows here
[img]http:z.uvw.com/7862252...
[img]http:z.uvw.com/4621017...
[img]http:z.uvw.com/4728212...
[img]http:z.uvw.com/78293.5...
download url follows here
[url]link2[/url]`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}