# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[img\].+\n)(\[img\].+\n)*"
test_str = ("subject1\n"
"image url follows here\n"
"[img]http:f6.abc.com/246421f...\n"
"[img]http:f6.abc.com/246421d...\n"
"[img]http:f6.abc.com/246421h...\n"
"[img]http:f6.abc.com/246421m...\n"
"download url follows here\n"
"[url]link1[/url]\n\n"
"subject2\n"
"image url follows here\n"
"[img]http:z.uvw.com/7862252...\n"
"[img]http:z.uvw.com/4621017...\n"
"[img]http:z.uvw.com/4728212...\n"
"[img]http:z.uvw.com/78293.5...\n"
"download url follows here\n"
"[url]link2[/url]")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.